This incident has been resolved, if you encounter any errors please let us know by emailing Support
Posted May 16, 2025 - 16:03 CEST
Identified
We are aware that our water portals are currently not reachable. We have identified the issue and are working to solve this asap. This has no effect on the sensor data or notifications.
Posted May 16, 2025 - 14:13 CEST
This incident affected: Env: Water (Customer Portal).